Reebok jet 300 treadmill e02 error - does not work

edited January 2023 in Treadmill Problems
Hi everyone!
I have a really mysterious case with my Reebok treadmill! Sherlock would love to participate I am sure!

Precondition: once upon a time I turned my TM on and heard beeeep “error 02 - Motor stall” -> no move, dead. I would think it happened because I never lubricate (for two months I have this TD) canvas and it just overload motor-> PCB stuck. I Have a guarantee -> called technician to fix it. For sure Tech brought both new Motor and PCB. Replaced -> the same result. Tech said “ohhh they send me a not working PCB” and ordered another one. Another one arrived and Tech replaced one more PCB and checked one more time -> the same result. Tech just said something like “ohhhh something is not working just ask to return your TM and get your money back”. This guy looks fantaastically unprofessionally (like student intern on vacations for quick money).
1. turn on power - > TD beeps and shows on the display a normal info like everything is ready to start.
2. I click the ‘start’ button -> TD counts 3,2,1 then beeeeeppp and on the display I see “E02 - Motor stall”.
What components I have as the result:
1 TD , 2 motors, 3 PCBs:)
What I have done to be sure (yes, in parallel watching all “how-to” videos and guides in youtube):
1. Checked motor(default one and a new one) with multimetr - no short; connected directly DC battery source (9-12V) to see it works fine.
2. Checked speed sensor - with magnet that it works; with TD on and manually rotating td canvas - no error is shown as electronic ‘thinks’ that everything is okay as sensor is working.
3. Checked main capacitor (450V) - desolder it and checked resistance is growing 500-600-700-1 like expected; checked it in PCB circuit with power on and it shows 180 VDC and 320ADC.
4. Checked visually all PCB elements - nothing burned, or looking bad.
5. Checked rectifier bridge (4 pins) -desolder and no short.
6. Checked IGBT (3 pins) - desolder and no short.
7. Checked fast r diode (3pins) -desolder and no short.
8. Checked AC/DC on PCB: turn TD power on -> checked AC on input PCB contacts and = 228-232VAC - > checked VDC on output contacts (connection to motor) = 11VDC.
9. Connected the new motor is not connected to the canvas/belt and on the ‘start’ button click it moves slowly for 3-4 seconds and stops. Then I click the ‘stop’ button and then again ‘start’ button -> motor rotates for 1-2 seconds. One more time this - very slow 0.5 -1 seconds move. On the forth time motor is not moving. Power off -> power on -> the same scenario works again.

Mystery and thoughts about it:
1. Yes, I am checking PCB elements but what confuses me that I have THREE PCBs (two of them are totally new - just from the manufacturer let’s say) and two motors (on is new) -> how it could be that all three PCB are down/bad?
2. I see only one scenario why all three pcbs became bad -> ‘Tech’ guy first time replaced motor and make really huge belt tension -> all new PCBs were “broken” accordingly due to this belt tension….(also sounds unrealistic -> perhapse PCB has some safety mechanism for this?)but If that is true then with motor connected to working PCB but disconnected from canvas I should get everything working.

Next steps:
1. Right now I have only one thing in my mind -> somehow to trace a path of voltage from the capacitor to motor outputs. But if it fails due to some electronic action -> then I do not know.
2. Buy forth PCB but not sure it will help,but not sure…mystery.
2. Get any possible help here. could you please consult considering the information above about possible validations?
Thanks a lot!


  • what is the model number of this machine?
  • Reebok Jet 300 model with Pcb-zyxk9-1012b-v1.1 and usual Magnet DC motor 180VDC.
  • Where are you getting that board? This must be an old machine.
  • That makes sense now. are you sure the replacement boards are new? could they be reconditioned?
  • I am not sure how to determine if 'reconditioned' but visually PCBs look like new (compared with a good quality images from aliexpress :) )
  • Well, what you are describing above sounds like a motor controller. you might reach out to the manufacturer there because the reebok here is incompatible with the one you have.
  • 'motor controller' you mean PCB right?or there is some piece of PCB called
    'motor controller'?
    already googled this PCB and this is some 'noname' from China so I do not think I can find any leads. But I can buy/order another new PCB to be 100% sure :smile:
  • the picture of the board you sent is a motor controller. it is a pcb (printed circuit board) but called a motor controller.
  • "reebok here is incompatible with the one you have" - sorry, but what do you mean by this?

    This PCB was initially installed in this TD when I bought it and it was working for 2 months, but then got error :(
  • reebok in Spain is not the same as in the USA
  • edited May 2023
    here the behavior I have identified: 1) starter capacitor after power turn on is gaining direct voltage but very slowly. 2)I wait till it gather maximum (220vdc) 3) then when I clicked start button on the TD -> voltage goes and the motor is working several seconds while this voltage is enough, but when capacitor is empty -> motor stops. Any ideas?
    checked another working capacitor - 320vdc I can see always on this capacor (just standby mode or 'start' click)
  • I track the scheme : 1) from AC path goes to relay 2) from relay it goes to bridge rectifier 3) from rectifier it goes to ‘starter’ capacitor’ 4) from capacitor it goes to Fast recovery diode (what you call MOSFET seems) 5) from FRD it goes to DC outputs.

    I do not hear any clicks from Relay - > perhaps relay does not work and does not switch start capacitor and run constant voltage...
  • that is a possibility
  • re-checked and the relay does work...everything works but once 'starter' capacitor sends all voltage - motor stops :( ..
  • that sounds like a motor controller failure
Sign In or Register to comment.