Sportstech F37

I had a new F37 which worked fine for 3 weeks, the belt then slipped while I was using it, then started again as normal then 5min later it slipped again and it stopped working. Thereafter everytime I tried to start it it went through the start up mode and count down, the belt started and after 1/2 a resolution it stopped and shut down, this kept happening every time I tried turning it off and restarting it. Sportstech said it was the PCB and sent me a new replacement however I replaced the PCB and it did not fix the problem. The treadmill goes through the start up routine, starts and the belt does 1/2 a resolution before it shuts down. I'm in contact with Sportstech again as it is a brand new treadmill but any thoughts on what is wrong?


  • GM!
    Does the treadmill operate normally without a person on the belt?
  • No the issue above occurs without anybody being on the treadmill
  • Sounds like a motor controller or drive motor.
  • If the motor controller is part of the PCB then I have replaced that with a new PCB. Are the motor controller & drive motor both part of the main motor unit or are they seperate components? The Motor runs and turns the belt but then it shuts down so the motor must be working or partly working before something tells it to shut down.
  • The pcb is up in console, the motor & controller are under the hood cover down below.
Sign In or Register to comment.