Treadmill incline not working

Hello all. Over the weekend, I picked up a used Nordictrack 2950 model NTL22113.1. This is my second 2950 as the original one the console board is having issue as well as the motor controller board. On the one I picked up, All works except the incline. In looking at the incline motor, I see a small fan on the top part which is not spinning which I believe it should be spinning. How do I troubleshoot if the issue is the incline motor or something else? Thank you


  • carefully give that little fan a push with your finger as you're trying to increase the incline. Sometimes that will free up the motor.
  • Thanks Kevin. I had actually tried that over the weekend and just tried it again. Doesn't do much. Does this mean it is the incline motor that is dead or should I look at something else before such determination?
  • When you press the buttons on the console do the buttons beep at you?
  • Yes and they show the incline number selected on the console.
  • unfortunately, that motor is listed as out of stock
  • So I decided to swap incline motor from the other 2950 treadmill I have and same results. The incline would not work. Now, both incline motors tested on my original 2950 and both work just fine. Would this be an issue with the motor controller board or something else?
  • motor controller
  • Actually I think it the console itself... I just swapped out the motor controller board with the controller from my original treadmill that I have, and it did the same thing. Would not incline. I then took the controller back to the original treadmill along with incline motor and it worked just fine. Anything to check on the console? Any calibration or reset needed? Or another control board that I need to look at?
  • There is calibration for it. check under the settings button if it has one. if not,
  • Last night I had found within the menu the incline calibration option and attempted it. Unfortunately I get an error message "the calibration process has failed. Please try again". I also tested power to the incline motor and I am getting the 120 on the meter.
  • I'm starting to think the console is the issue too!
Sign In or Register to comment.