Proform 520e beeps constantly and sets resistance to max.

Our Proform 520e PFEL55916.6 has developed a malfunction where as soon as I plug it in it begins beeping and it sets the resistance to 18, the max. No buttons on the console work to lower the resistance, the only button that seems to do anything is the ifit sync button, if I hold it down the beeping stops until I let go. I have read of a similar problem and a tech suggested the tension motor, I suppose that's possible, but would that result in a non-responsive console? It seems like a stuck button to me, but I'm not a exercise machine tech. The console doesn't have buttons that move, it's a big slab, the buttons may be capacitive or a type that registers a tiny bit of flex in the panel. Any suggestions would be appreciated, I see the motor is available here, and I have found a discontinued console, but I don't want to buy the wrong part. Thanks for reading!


  • Has the machine been taken apart or moved? this could be a wire harness issue. Or a stuck/malfunctioning button on the console. Open the console and disconnect the buttons from the main board. if the problem goes away, it's the membrane/buttons and will need a new console.
  • Hi, thanks for your reply. The machine was moved but it worked correctly for months after. I did buy a tension motor for it, but the problem remains. I actually carefully lifted the button membrane off of the console and tested, same result. I guess I need a console, unfortunately they're rather expensive, I guess the only way to know will be to swap it out.
  • Here is a link for the console;
    Here is a code you can use on the checkout page for a 10% discount (10offkevin)
Sign In or Register to comment.