Epic 400 MX Control Panel stops working save for two buttons

So after having trouble with a Urevo treadmill I bought, a friend reached out and offered me his Epic 400 MX treadmill for cheap. I picked it up Saturday and on Sunday I went for a 20 minute 2 mile run and everything seemed fine.

Today after work I hopped on again and ran my 2 miles, but when I tried to slow down none of the buttons worked. I had to disconnect the emergency switch and then power off the machine to get it to stop. I restarted it and found that only 2 keys on the control panel, the incline buttons for level 2 and 7, work.

I got a power tool and tried unscrewing the control panel, but I didn't want to start pulling off the wires. I thought the issue was that it was loose and maybe the pressure points for the buttons aren't close enough, but the two buttons that work aren't next to each other so I'm not sure if that is even the issue.

Anyone have any ideas?


  • So I turned it on this morning and it seemed to be working again, with the control panel seemingly fine. I turned it back off, turned it back on again, but then the buttons didn't work again same for the 2 and 7 incline options.
  • Could be in the keypad, sometimes if you take apart console and unplug the ribbon cable that goes from the PCB, to overlay and clean the ends and then reinstall it sometimes will fix issue.
Sign In or Register to comment.