Cybex 900 Treadmill incline/decline issue

After a limit switch got stuck, the treadmill declined all the way down until the chain on the incline/decline mechanism broke. I disassembled everything, repaired the chain, cleaned and tested both switches.

On startup, the I/D motor moves a bit and the optical sensor spins approximately 1 revolution and then stops. There is a -- on the dispay for I/D.

The treadmill operates fine other than that. I am getting errors 12 and 13 even after clearing the codes.

Is there a calibration sequence for this model? Can someone give me an overview about how the switches and optical sensor work together?

I have not tried removing the motor to ensure it is not stuck, so that is something I can try.

Any help would be appreciated.


  • I will email your the service manual and error codes.
  • Thanks. I have the service manual and the code descriptions, but it doesn't really tell me much about the optical sensor and how the whole system works.
  • Thats all we have , cybex no longer supports that product because of its age.
  • Here you go. R08-291600123
  • were you able to run any of the tests for the incline. going into the engineering mode may give a little insight into what is wrong
  • @KevinC, how do you put it in enineering mode? Or is this the same as troubleshooting mode?
  • it starts at section 4 of the service manual. if you don't have the one I have, message me your email and I'll forward it to you. it's too big to copy paste here.
  • Thanks. I have the manual and have worked through section 4 with no luck.
  • There is a flow chart too. did you see that? Problem here isn't that we can't figure out what's wrong with it. the problem is getting parts for it. anything you find is going to be a used part.
  • I got it sorted out! I had connected the right-hand limit sensor wire (upper) to the wrong terminal. It appears that the switches have two modes depending on which terminal you use: normally closed, and normally open. Changing the wire to the other terminal remedied the issue. Thanks all.
Sign In or Register to comment.