rkrish999

I bought a Reebok 9500 ES motor drive belt from treadmilldoctor (treadmill was slipping). I opened it - the old drive belt had a strip worn off. When I tried to put on the new belt it doesnt go over the pulley on the front roller. Its as if the front roller's white pulley has slipped inwards toward the middle of the roller, so the drive belt covers only half the pulley. Is this normal wear and tear and will a new front roller solve the problem?

About

Username
rkrish999
Joined
Visits
1
Last Active
Roles
Member

Activity

  • I bought a Reebok 9500 ES motor drive belt from treadmilldoctor (treadmill was slipping). I opened it - the old drive belt had a strip worn off. When I tried to put on the new belt it doesnt go over the pulley on the front roller. Its as if the front roller's white pulley has slipped inwards toward the middle of the roller, so the drive belt covers only half the pulley. Is this normal wear and tear and will a new front roller solve the problem?
    November 9
    • rkrish999
      rkrish999
      Looks like the solution is on the web site itself; I tried it and it seems to work!
      It says that my drilling couple of screws through the pulley into the roller's metal it will hold the pulley in place. I had to gently tap the white pulley on the roller back towards the edge first. Only doubtful part here is if the puller is perfectly aligned with the roller (or it will have some sway as it rotates). I just did it by eye and it seems OK.

      Lets see how it hold up.

      Thanks TreadMilldoctor!!