ProForm Elliptical Support Forums?

Does anyone know of any specific ProForm Elliptical support forums?

We just got a Carbon E7 and the resistance seems very hard on the lowest setting.

With it unpowered, it is easy to start, then after a minute or two gets much harder.

There is a vertical calibration in the manual and control panel, but nothing about calibrating the resistance.

Any help would be greatly appreciated.

Jerry

Comments

  • I heard that Treadmill Dr had a pretty good forum lol :smiley:

    What is your model and serial number?
  • Sorry, I am really grasping at straws here. ProForm is not answering support questions.

    Carbon E7, Model number: PFEL59920.0. Serial number: NN520G0001522

    Thank you!

    Jerry
  • I apologize for my levity! Here is what I found in your service manual pg 22...

    To change the resistance of the pedals...:

    Touch Manual Start and begin pedaling.

    You can change the resistance of the pedals by
    pressing one of the numbered Resistance buttons
    or by pressing the Resistance increase and
    decrease buttons.

    Note: After you press a button, it will take a
    moment for the pedals to reach the selected
    resistance level or for the ramp to reach the
    selected incline level.

    So it looks like you have to manually increase and decrease the resistance of the pedals!

    Let me know if this does not work and we will continue forward in this quest for knowledge!
  • edited September 16
    Ha, no problem for the levity, we certainly can use some more here which I will attempt at the end.

    And ha! Did I mention I did read the manual? I think I did. :-)

    The question is why, with no power at all, not even plugged in, does the resistance change after a minute or two?

    The other question I asked tech support at ProForm, which also was totally ignored, was:

    Is the resistance with no power on supposed to be the same as the lowest powered resistance level.

    But, I'm going to make a funny guess that you don't know the answer to that either.

    :-)

    Anyway, I really do appreciate you trying to help. Thank you.

    Jerry
  • when there is no power unit should have very little to no resistance

    The lower board may still have a charge in the capacitors which can cause motor to move a little at times, but not much.
Sign In or Register to comment.