Kettler I-Run E7

Hi there yet another problem with a treadmill!

I have a Kettler i-run with an E-7 message on the console. I've just had the control board fixed after a DC-6 error it had previously. Now it will run for a few seconds and stop to display a E-7 message which after a little research seems to point to a bad incline motor. I have had the motor off the machine and tested it and the shaft spins but doesn't go up or down. Is this a case of a bad incline motor or is there anything else I can check or test to work out what exactly is wrong with it? Or is the error something else?


  • How did you test motor when it was outside unit?
  • I pulled the motor out of the treadmill and tested it but taking the white console power lead and attaching it to the red or black wire alternately to go up and down which worked. It just seems to not be getting any signal from the console. I've tried a motor from a completely different brand and it seems to work albeit with a few quirks as its a different setup to the J-Star on the treadmill. This seems to point to something wrong on the incline motor itself. I am thinking of just buying a new incline motor for it as this will probably be easier than trying to fix it as I am not really sure of the internal workings of the motor itself. I can't find the exact same model but it can find similar ones. Would this be much of an issue. Quite a few of the Roger Black Gold editions seem to have a similar model of motor. Would that work?
  • Contact kettler
Sign In or Register to comment.