E1 code - Xterra T900 - Tried everything...

Hi friends,

I will search on the forum for more, but I want to share this issue as I'm now completely stuck and desperate…

I bought an Xterra T900 (Dyaco/Horizon) about 4 years ago, used it a while, then left it to dust for 3 years before I decided to start working out again about 2 months ago.

Last week, it triggered an E1 code after a couple of minutes of use, thought it was due to use of bad extension chord, unplugged-replugged and back to normal. 2 days later E1 again so I decided to check-unplug-replug wires of arm keys, got back ok. 2 days ago after like a 15m run it started to change speed on its own, and even if I could hear the bips while pressing arm keys or console keys, it would just not adjust. It eventually slowed down after a couple of minutes, then went fast again etc. And now it's over it just triggers the E1 code 6-8 seconds after the belt starts moving.

- I cleaned it all
- I tried to disconnect/reconnect fast key connectors in the arms
- I tried to disconnect/reconnect console keys
- I lubricated the belt
- I opened the motor box and plugged/unplugged all I could
- I cleaned and adjusted the speed sensor
- I checked magnetism and cleaned the magnet near the speed sensor
- I checked all visible wires to see if any of them was in bad condition
- I tried to loosen/tighten the belt tension
- I looked for bulky capacitors on circuit board
- The motor does not sound weird nor smells anything burned

I have no idea. How could I tell if I need to replace the speed sensor, or if there's an electronic failure on the mainboard?
The motor could be faulty but I think it's not very likely as the belt starts moving and I never had any indication of motor problem such as burn smell or noise.

Any advice / test suggestion would be much appreciated.



  • EDIT: I just did the motor test with an 18V drill battery: motor spins the belt perfectly.
Sign In or Register to comment.