Proform 505 CST treadmill with iFit app

Today I tried to use the iFit app with my Proform 505 CST treadmill for the first time in a long time (probably about 7 years). I paired the treadmill with my Android phone. Initially, the app couldn't connect with the treadmill. When it finally did, it got into a loop - from the home screen, the display would rotate into landscape, show an error something to the effect that the treadmill's firmware needed to be updated and to see the User Manual for instructions. When I tapped "OK" on the error, the display would rotate back to portrait, go to the app home screen, then immediately repeat the process. I force-stopped the app, cleared cache, and restarted the app, but the same thing happened. So I uninstalled the app, and reinstalled it from the Google Play Store. Signed in, the treadmill connected right away, and the app immediately displayed my current workout stats. During the workout, I used the app to increase the belt speed. So far, so good. When I finished my workout on the treadmill about 20 minutes later, and stopped it, the app also stopped the workout and displayed my final stats. I saved the workout on the app. The app then displayed a message that there was an update available. I don't recall the exact wording, but there was no question in my mind that the "update" was for the treadmill, not the app itself. And since I had just done a fresh install of the app from the Play Store, what update to the app could possibly be available? Anyway, I tapped "Update" (or "Ok" or whatever) on the message. The app display then said something like "Update in progress. This could take several minutes.". The treadmill display went dark - but not completely off; I could still see the image/numbers very faintly. After about 2 minutes, the app said the update failed. And now the treadmill will not turn on. I was on chat with Proform for about an hour, twice with parts & service, twice with software. Both told me that there is no software on the treadmill to be updated. But I still say the "update" bricked the treadmill. I took the motor hood off to see if there was anything glaring that I could fix. The only thing that jumps out at me is on the controller. When I plug the treadmill in and put the switch in "Reset" mode, there are 2 LEDs that come on on the controller. The first one comes on green right away. The second comes on red after a second or two or three. Is my controller fried? How difficult is it to replace? Any suggestions? TIA


  • I really don't think this is the controller. This is a software/firmware issue with the console/display.
  • edited February 14
    Leaving this here if anyone one else should need it...

    I found the FAQ on the Proform website for "How do I install a firmware update?", even though 4 different people (or one person using 4 names and 2 email addresses?) told me that there is no software or firmware on this treadmill to update. And lo and behold, step #6: "If the update happens to fail, close the app then reopen it. Attempt the update until it successfully installs." Much to my surprise, even though the console looked dead, I was able to connect the iFit app to the treadmill and attempt the update again. Which failed, again. But the third time *was* the charm, and it worked. The treadmill is now back up and working as it should.

    Orig: Thank you for your reply. Proform (both P&S and software) told me that my model (PFTL60916.3, bought in 2017) doesn't have *any* software or firmware on it, or at least none that can be updated. Do you know of a way to do a factory reset on it? Or is there no hope, other than paying Proform for a new console?
  • I've seen this before with these machines. the only way is to replace the console.
  • I think what they mean is they just don't support it any more.
Sign In or Register to comment.