Treadmill console works but belt / incline does not (Proform Endurance M7)

Hi everyone,

The intro:
I recently bought a second hand treadmill that was around 3 years old. I tested the treadmill before purchasing and it worked fine, I also tested it after transporting the treadmill from the previous owners garage to my outdoor decking and it was working fine. The next morning, I decided to go for a run and after turning on the treadmill, the console turned on but selected a speed or incline would only show the value on the console but the running belt and incline would not move.

The possible cause:
The one possible cause for the issue I can think of is that my partner decided to clean the outdoor decking while the treadmill was on and some water may have splashed off the decking and onto the lower control board. However, after opening up the lower treadmill control base, it looked bone dry. Still very dusty and no moisture to be seen. That said, I'm assuming any amount of water that hits the control board isn't good.

The diagnosis:
I don't have a background in electrical components so my diagnosis involved a lot of Googling and Youtube videos. This is troubleshooting steps I've done so far:
- The obvious turning it on again and off again
- Tried recalibrating the incline
- Tried unplugging and replugging wires connected to the control board
- Tried a continuity test on the belt motor using a fork

After my amateur diagnosis, this is what I've found so far:
- The LED on the control board lights up and is solid red (I've read that it should be blinking)
- The continuity test on the belt motor suggests the belt motor is fine (definite friction when connected to the fork)
- The incline motor moves slightly up and down when the treadmill is powered up (which I've read that it shouldn't)
- The treadmill appears to be stuck on a slight incline (nothing below the treadmill obstructing it)

Here is a video of the control board when the treadmill starts up.

I'd really like to try and fix this myself as the whole point of buying a second hand treadmill was to avoid too much money. Does this issue sound familiar to anyone or are there any other trouble shooting steps you could suggest?



  • When you press the start button that light on the motor controller should start to flash. Double check the wire harness for a damaged wire.
  • I've checked the wire harness for any signs of visible damage but couldn't see any. Is there a way to test the wires to see if any are faulty?
  • yes, you'll need access to the top and bottom sections and you'll need a multi-meter set to resistance/ohms. You're checking for shorts between the wires or between wires and ground.
  • Thanks! Will look into it.
Sign In or Register to comment.