Two months old.... NordicTrack EXP 7i quit working. Only getting a white screen with blue logo.

I'm lucky to have found this site, and hope someone can help me out on this issue. I bought a NordicTrack EXP7i two months ago, and it's seen minimal use. Now that the weather is colder, we've started using it more, and just recently my wife found that the normal screen for the treadmill wouldn't come on. Also, the only thing that would function is the incline/ decline. That recently changed also as now nothing works except the white screen.
I tore it down to see if a wire had come loose as I know it has power, but found no loose or broken wires. I tried the pinhole reset, and while that did show the bar on the screen as it reset, it always goes back to the white screen with the logo and won't go any further. Any suggestions on what to try? It seems that the only thing that's getting power is the screen.
I tried to paste a picture of the screen, but I'm not able too. It's a completely white screen with a blue logo somewhat like this > in the middle that just blinks.
Thanks in advance for any help!


  • This is a software issue. If you can get me the specific model number of the machine I'll check to see if there is a way to reinstall the software.
  • Thanks Kevin! The model number is-
    I appreciate your help!
  • The only thing available for this one is the replacement console.
  • Hello Kevin. Thanks for the info. Since I last posted, I talked with a local NordicTrack repairman who stated the parts are all still under warranty. I've reached out to NT customer service who started a repair request, but haven't heard back from them since. Thank you for the help!
  • This is the exact model that I have and my incline calibration keeps failing since I got it over a year ago. I just installed a new incline motor and no luck. On the circuit board when i do the incline calibration, LD5 is red and LD4 is yellow. what colors are they when the calibration works?
  • your best bet would be to reach out to the manufacturer to see if they have an update for the software/firmware. in my experience, this is caused by corrupted software in the console.
Sign In or Register to comment.