Proform PF 3.6 doesn't move.

edited October 2021 in Treadmill Problems
Hello all.
I'm here because I need to fix an issue with my brother's treadmill.
It's my first time trying to fix a treadmill but I've been fixing other kind of devices all throughout my life.

Here's the problem:
I press start or any speed button and it trips the circuit breaker (in the panel, not on the treadmill or the socket).

Beforehand I must say that this treadmill has worked fine for many years in 3 different houses, all of them had sockets protected by circuit breakers. It was bought in the 2000s so it's ~15 yrs old now. At some point about 6~8 years ago the treadmill started having this issue. Initially it was intermittent but then it became a permanent issue. There was never any attempt to fix it until now.

Here're relevant facts:
- It began happening on one house and now it's happening on another that is newer.
- Different sockets have been tested and even different power cables.
- I've opened it, there was almost no dust in it (to my surprise because I've seen another treadmill in the past full of dust and I was expecting the same) and it appears to be in good condition and there's nothing immediately suspicious.
- The LED of the controller board is lit when it powers on.
- The inclination motor works fine even with someone over the treadmill.
- The LCD panel is fine and I was even able to access an internal menu which revealed that it had already completed about 1600Km.
- Tried moving the belt myself and starting it while moving (to reduce the effort to the motor) but still it tripped the CB.
- When I move the belt by myself the speed is correctly detected (meaning the speed sensor is fine).
- As it all points to something related with the motor (or the transformer for the motor) I temporarily disconnected the wire that controls the motor's speed and I could start the treadmill except (evidently) the motor was not moving.
- I'm at the EU with 220v 50hz power, and with Type F plug (and socket).

I only wish I could have access to spare parts so I could try them for myself but as I don't have them I really have to ask for help before I waste money on something that may not solve anything.

So please, if anyone has any clue on what is happening or how to fix it please tell me.
It would really be a shame to throw away a treadmill that seems to be in good condition just because one component is bad.

Thank you.

Forgot to mention that it tries to move before tripping the breaker. It always moves maybe 1 or 2 cm.


  • Sounds like a bad motor, You don't have it plug into a arc fault circuit, if so ut will trip every time.
  • I'm not sure if they're arc fault but it tripped in sockets where it once worked so it shouldn't be that. Anyway, I'll try to run the motor from a battery (as seen on one of your videos). I didn't knew a battery would be enough to make it run (different voltage and probably not enough current... but judging by the video it is enough). I'm only afraid of buying a motor and the problem being somewhere else and then spending the money and not solving, but with the battery test it will probably help me figure if I need a new one.
    Did the 9V battery test.
    With the driving belt in place, it doesn't move (it tries, but can't) and the battery heats up.
    Removing the driving belt, I'm able to make the motor move.

    Here's a quick video showing the test:
    please watch and tell me if the motor sounds ok
    (and ignore the stomping in the background... it's not the motor)

    More things I've tried:
    - Tried to run the motor (from the controller/treadmill) without the driving belt... still trips the breaker, but moves more than with the belt on (makes sense...)
    - Tried to run the treadmill (without power to the motor) and checked the voltages on the connectors... at 2Km/h it was ~8V and increased correctly as the speed was increased (so it seems to be fine).
    - Measured the motor electric resistance when stopped and it was 1.2 on the lowest scale (miliohms, maybe...). Evidently the resistance increased when I moved the motor.
    - Did a continuity test to the motor, when stopped it has continuity (it beeps) but when I move it it doesn't have continuity.

    Something I forgot to mention on the first post was that sometimes when I try to run it normally something starts smelling burnt (the typical electric burning smell). And sometimes there's a spark near the fan part of the motor.

    Please tell me if this still looks like a bad motor or if there is still hope that it isn't.
    I just want to be sure that it's the part that is bad so that I can be sure what to buy to fix it.

    Thank you.

  • Motor should spin when drive belt is hooked up, I would try a 12v battery or 18v battery, 9v may not be strong enough to move motor with drive belt in place.
Sign In or Register to comment.