BodyGuard T240 High Pitched Whining Variable with Speed

Hi,

I just replaced the running deck and belt on my Body Guard T240 treadmill. As the belt speeds up it is making a very loud high pitch whining sound. I isolated the motor and front roller, by removing the running belt and operating the motor and these don't make the sound. I also removed and checked the rear roller and those bearings are spinning smoothly with no apparent sound. It seems like it is just the belt making contact with the deck that is causing the sound, but it wasn't making this sound before.

The deck that I purchased from FitnessRepairParts is significantly thicker than the original, but it doesn't seem to be impeding the operation of the treadmill and otherwise it fit perfectly. Other than the sound, the treadmill feels great, solid and no slip on the belt. The replacement belt was purchased from Walking Belts LLC. The belt came with a lube bottle, which it said wasn't required until about a year from purchase, but with the sound I decided to try it anyway. It didn't help.

Here is a YouTube video of the issue. You'll see what I mean.

The video starts around 4MPH and at the end I increase the speed to 6MPH.

Any assistance would be appreciated.
Thanks,
Rob

Comments

  • As an aside, I didn't find the parts I was searching for at Treadmilldoctor.com, or I would have bought the parts from you. they were very hard to locate.
  • The reason the belt is making so much noise it that because the deck is thicker then the old one the belt will rub on the front edge of deck which will wear your belt over time. Your old deck was 3/4" and the new one is 1" thick. If you are handy you can take new deck out and bevel the front and rear edges of the deck and that should help.
  • Thanks so much for the response. This makes sense. From your response you sound like this is a scenario that is familiar to you. Did they increase the running deck thickness for a reason? Do you have a recommendation on the angle of the bevel? Is a longer bevel better, or do I just need to take the right angle off? Thanks again for the assistance.
  • They sold you the wrong deck thickness, so the best thing is bevel the entire front edge of deck enough that belt does not rub against front edge when it comes off roller, you may have to do that same at the rear of deck also.
  • Ok great. Thanks for your help. I'll run out and get a round-over router bit and take the front and back edges off. For future reference do you sell parts for the T-240? For example could you have gotten me the correct thickness deck?
  • Yes we have the decks, all we would need is the size of the old deck and we custom make them in our warehouse.
  • Hi, Just closing the loop on this issue. I used a 1/2" round-over router bit to round both the front and back edges of the deck. It may have made a tiny difference but the sound is still very loud and high-pitched. Thanks for the advice and for trying. It's possible that I could continue to make the bevel angle 'longer' and see if it gets better, but I think at this point I'll just see how the belt wears. We usually wear headphones anyway :smiley:

    Can you tell me what you use to finish your running decks? If I get over-zealous with a planer I'd like to know that I can reapply finish to any area that might need it.

    Thanks again, and I will be sure to come to you for future purchases. Your 'competitor' offered 0 assistance.

    Thanks,
    Rob
Sign In or Register to comment.