Display console has no power Nordic Track c2155

hello thanks in advance for reading
I bought a nordic track c2155 that was working before I brought it home, and when I plugged it in there was a loud pop and a spark from the motor. I bought a heavy duty surge protector and here's where I'm at:
-The display console gives no indication that it has power/does not light up.
The control board has a solid red LED on, indicating that it is receiving power.
Here's what I have tried so far:
I know the treadmill is getting power to the base as the LED is on and solid. I have checked, unplugged and replugged all the connections, both at the control board near the motor and in the motherboards of the display console.
The fuse is intact, and so is all the wiring.
The reed switch has a tiny chip on the end, was probably damaged previously or during transport yesterday- I've ordered a new one and am praying this will fix the problem but I have my doubts. Shouldn't the display console have power even if the reed switch is malfunctioning???
I'm thinking it's possibly the control board to the display console, but my main question here is can a faulty reed switch cause the display console to not turn on or light up at all?
I also have a multimeter on it's way to me, but learning how to use it will be a whole other can of worms.
I'm so in love with this treadmill and want to fix it so bad. Thanks again

Comments

  • You want to check for DC Voltage up at console on the red wire & the black wire, should have 8 to 12 vdc.
  • thanks for the reply. I tested where the red and black wires plug in up at the console and did not have voltage. I also checked down at the control board where the wire from the console connects nad didn't really have a reading there either.
    Does this suggest I need a new control board? I see where you are selling them on amazon. If I buy one but it does not fix the problem, will I be able to return it? thanks
  • Yes that means you will need a new motor controller, and yes if that does not fix issue you can return it.
  • edited June 7
    hi,
    update: I bought the control board and it did fix the problem I was having with the console not lighting up= it does now.
    New problem: The walking belt slows down or sometimes stops when I step on it. Seems to run just fine without any weight on it.
    I'm concerned it could be an electrical issue as I wasn't having this same trouble a few weeks ago before the control board blew out, and it seems too sudden and coincidental that also the belt went bad at the same time.
    I am new to using a multimeter but I did test the area where the incline motor plugs in to the control board and am not getting a reading. When I tested where the belt motor plugs into the control board it read around 20v dc but rapidly decreased reading, the lower the reading went the slower it decreased. After about a minute of watching the number go down it was at 1.5v and still decreasing but very slowly. What are your thoughts?
    Thanks for your advice
  • couple more notes: the walking belt appears to be at about the right tension (lifts up about 2 inches) and I have lubricated it recently.
    When I start the machine the red LED indicator on the control board blinks steadily/rapidly
  • edited June 7
    edited in first comment for clarity
  • Make sure you calibrate new motor controller, also with that red light blinking-If light is on and blinking rapidly - AC power is present, it is receiving a speed signal and is outputting DC voltage.
  • hm I did the speed calibration, and unfortunately it is still the same. I there another type of calibration I should be doing?
    It sounds like you are saying the blinking light means things are working normally, correct?
    I'm close to giving up but would love to be able to make this thing work
    thank you!
  • Sounds like you may have a issue with the Drive motor itself, Not strong enough to run with a load applied to it.
Sign In or Register to comment.