Sole F63 Won't slow Down

I recently bought a 2nd hand Sole F63. The treadmill will speed up just fine but it will not slow down. When you hit stop to pause the workout, it does not stop. You have to hold down the stop button to get the motor to turn off or pull the emergency stop. I have already replaced the speed sensor and ran the calibration and it still doesn't slow down. Any suggestions?


  • could be a issue with stop button in console
  • If the treadmill doesn't go over 2.0mph, the stop button works. It pauses the treadmill and will stop the workout. The treadmill also maintains the fastest speed that you put it on. If you set it to 4.0, then want to go back down to 3.0, it will not move from 4.0.
  • Any update with this? I have the exact same problem. It's not the stop button as the control panel as the buttons work perfectly fine to speed up but you can't slow it down at all below the currently set speed. The control panel displays is able to display the speed as slower (and even stopped) but the treadmilll physically continues to operate at the same speed.

    At first I was thinking it was a motor control board issue but I'm now wondering if the brushes of the motor are just dirty or worn out.

  • I have a Sole F80 that has the identical problem. I was going to replace the speed sensor, but noticed mrclean13 tried this and it didn't work. Suggestions?
  • Sounds like a console issue, you can unplug the ribbon cable that goes from buttons to main console and clean the ends real good then plug back in and see if that helps
Sign In or Register to comment.