Treadmill belt will not start...I know this is a common question but hear me out!

We have a Spirit xt185 that has been collecting dust until now. When you plug it in and power the unit up everything is as it should be. Incline is fine, display is normal... etc. When you hit Start it does its usual beeps and countdown but the belt never begins to turn. I have replaced the lower board (First had the board rebuilt, then tried 2 new replacement boards), and also a new motor. Still nothing. The people at Spirit will no longer answer my calls or emails. I am not sure if they are just busy or have no idea what is causing this. Regardless it is pretty sad customer service to say the least. I have lubed the belt and even tried starting the motor with no tension on the drive belt to see if it would at least spin. The only way it will spin is when I hook the motor leads to a battery. I am fairly handy but this one really has me stumped. Any ideas of what I might be missing?


  • I did not run voltage tests. I am not very savvy when it comes to using electric meters. The hard part is that no one will make a house call with covid. The company that sold me the treadmill offered to fix it but I have to bring it to them. Which means moving it from the basement, and then when fixed back again. With it being just my wife and I that is somewhat difficult. I will read up more on how to perform voltage tests and go from there. Thanks for the reply.
  • We can try and find you a tech in your area if you would like to give us a call!

  • I have a Spirit XT385 and my treadmill is doing the same thing as Brewingguy's machine. It turns on, incline works, display works, but the belt doesn't move. The motor pulls the belt when hooked to a battery, so I think the motor is good. On the display, it does say "lube" in small letters, so I lubed the belt. Then I tried to reset the display thinking that maybe the machine would go back to working, but I can't find instructions for this treadmill, and even though they say resetting the display is the same for all treadmills, it didn't work on mine. The light on my circuit board is solid red, but there are two other lights that don't light up at all. Should they all be lit up or just one? One website said a solid light on the circuit board means that there may be an electrical short in the line that runs from the display panel to the circuit board. Even though that doesn't make sense to me, I would try that if I knew how. I would think it would more likely be a short running from the board to the motor, but I don't know how to do that either. There are only two repair guys in my area and they both say it may be a bad circuit board, but until I order the part for almost $300 and pay to have it installed $200-$300 to rule this out, they will not guarantee that this will fix the issue. That is, if they will even come out now that we are back in the Covid purple tier. Do you have instructions/videos on either what wires to check or how to reset the "lube" signal on the display for this treadmill? Any help you can give is appreciated!
  • if you have a light on the lower board that tells you that you have AC power coming into unit.
    If you have a voltmeter you can check to see if you have power going to console on the red wire & the black wire should be between 8 to 12 vdc.
Sign In or Register to comment.