Belt and incline won't move but everything else appears fine

Proform Performance 1450

At first just the belt stopped working but the incline would still work fine. LED stayed solid in response to attempts to change speed. Batter test indicated motor is fine. Oddly, I found that if I set the speed low and moved the belt with my hands or feet for a few seconds, the LED would start to flash and the motor would turn on and run the belt without my help but only for a few seconds prior to stopping again. I also got the motor to briefly start (and LED flash) a couple times by accidentally shorting something on the motor control board near where the reed switch wire is connected.

Based on what I had read, I suspected the motor control board. Sent the motor control board away for repair ( Board came back looking like new, all capacitors clearly replaced, and they said that after repair the controller successfully ran the motor on one of their in-house treadmills (albeit not a Proform Performance 1450). But alas, the repaired control board still doesn't run my treadmill :( To make matters worse, the incline no longer works either.

I've measured various voltages with my multimeter and found the following (on both the motor control board AND console board sides of the ribbon wire):

Black (GND): 0

Red (power): 12 VDC

Blue (PWM): 0 VDC. I understand of course that the square-wave PWM signals expected are difficult to measure with a multimeter but a non-zero value should be observable when the treadmill speed is set to max. But the zero signal is consistent with the solid LED as I understand it.

Green (tach): 3.3 VDC. It's my understanding this is supposed to output 0 or 5 VDC (depending on position of reed switch). Regardless of the reed switch position, it's a constant 3.3 VDC. I've measured the resistance across the reed switch and confirmed that it changes between 0 and infinity depending on position of the magnet, as expected.

Violet (incline sensor): 3.3 VDC. Same as the Green.

Yellow (incline up): 0 regardless of incline setting

Orange (incline down): 0 regardless of incline setting

So... any thoughts? Motor control board still suspect despite having been "repaired"? How likely is it that the problem in fact lies with the console board? What else can I test/troubleshoot to figure this out?

Any suggestions very much appreciated. Thanks!


  • Sounds like a motor controller is bad.
  • Thanks for the response.
    Forgive my ignorance, but why wouldn't a 0 VDC PWM signal on the blue wire suggest a problem with the console board? How would a bad motor controller board cause the console board to not output a PWM signal? Thanks in advance for helping me understand :)
  • Still like a motor controller issue to me.
  • Thank you for taking the time to respond.
    Here's an update for posterity:
    After speaking with three separate experts, all of whom first suspected the motor controller, followed by the wiring harness, I tried replacing both, but to no avail. Finally, I tried a replacement console (albeit a much simpler console than the one that comes with the Proform Performance 1450, but I don't really care about the touch screen and such) and that did the trick! So evidently this was one of those rare (as I understand it) instances where it was actually the console board that failed, despite the fact that nothing appears amiss in the console display.
Sign In or Register to comment.