Issue with Freemotion treadmill - belt no longer moving when treadmill started

edited November 2019 in Treadmill Problems
Hi everyone,

We have a 4-year-old Freemotion GS 2500 treadmill that we have never had a problem with until recently. Yesterday, I had been running on it for about 15-20 minutes and then stopped for a short 2-3-minute rest break. When I went to start running again and selected my speed, nothing happened. The timer on the screen started going as if it were running, but the belt was not moving at all. I tried unplugging it several times and trying again, but it still did the same thing. I then left it unplugged for the rest of the day and tried again earlier this afternoon, but the belt still will NOT move. Everything else on the treadmill is working. I can adjust the incline, turn the fan on and off, and use every single feature that this treadmill has, but it just won't start when I want to use it. Like I said, whenever I select a speed, the timer on the display starts going, so it obviously thinks that it's running, but the belt isn't budging. I should also mention that the last 2 or 3 times I used it, the belt would do kind of a hard jerk whenever it first started and then would be fine and I could run on it with no problems. Then, whenever I was doing walking speeds of anywhere between 3.5 to 4 mph, the treadmill would take FOREVER to pick up any speed. The belt would move incredibly slowly, nowhere near the speed that it was set it. Now, it's not working at all. Could it be the motor control board? If that's what it is, it looks like a relatively inexpensive part, but we would need to find someone to install it as neither my husband or I feel very comfortable taking on that kind of task ourselves.

Any advice/tips would be greatly appreciated! I am desperate to get my treadmill back up and running ASAP as I am currently in the middle of training for a marathon in Florida this winter and, living in New England, it is now way too cold, icy, and gets dark out far too early to run outside, so I heavily depend on this machine for my evening workouts after work during the cold winter months!


  • If motor test good , then you will need a motor controller.
  • edited December 2019
    I kind of figured that it's most likely an issue with the motor controller, especially since the timer on the display screen starts going as soon as we select a speed, but the belt doesn't move, so the treadmill clearly thinks that it's running, but the motor just isn't engaging. Fortunately, our treadmill is still under parts warranty for two more years, so I called the manufacturer (Icon Fitness) yesterday and they have ordered a replacement motor controller (they agreed that's mostly likely what the problem is based on my description) and will schedule a technician come to our home to replace it once it arrives. Our labor warranty was only good for one year and expired back in 2016, so they normally would have charged us $159 for the tech to come out, but they were nice enough to waive that fee as a one-time courtesy and we will get it fixed at absolutely no cost to us. Hopefully, it will be all good to go by then! I haven't been able to run or incline walk in several days now and we just had a huge snowstorm here, so I'm starting to get a bit grouchy and irritable! I've been using our stationary bike for the last few days, but it's just not nearly as satisfying as a good run to me.
Sign In or Register to comment.