Proform Perspective ES Belt and Incline Don't Work After Moving

After moving my Proform Perspective ES treadmill from one room to another neither the belt or the incline would work.

I removed the display and vertical support arms to move the treadmill from one room to another. The treadmill was moved and reassembled without being dropped or banged around. The only electrical part I touched was the ribbon cable that connects the motor controller board with the display. The pins in the cable were not bent.

When I turned the treadmill on the top display worked fine but neither the belt or incline would work. I rechecked everything and could not see any loose connections. It was getting late, so I went to bed.

The next day I got up and after visiting Dr. Google for ideas I find there are calibration tests you can initiate by doing the “Start” and “Up” button routine. Ah, something I can try. But when I plug the treadmill in the incline goes all the way up and stops. Previously it had made no sounds at all.

I ran the incline calibration and nothing happens. I do the speed test for the belt and it doesn’t move. I also checked the belt motor with a 12v battery. It checked out fine.

So, here is where I am now.
--Whenever I turn on the treadmill the incline motor, still stuck at its highest point, hums for a couple seconds and stops without moving. The motor hum had not happened until it unexpectedly rose all the way up.
--The red light on the controller is lit, but does not flash when I press any buttons on the console.

Model number: PFTL99806.0
Motor controller: MC2100WAM
I have my own opinion as to what is wrong but want to see if your more educated opinions jive.


  • Problem fixed. I thought I would answer my own post in case anyone else has this happen. I originally thought it was the motor control board and found a new replacement board on Ebay. But I first called and talked to the seller. He, very honestly, told me it probably was not the board. He suggested I do a continuity test, which I had not done. The test showed two wires were shorted and a third broken. When reassembling the vertical support arms I had evidently pinched the wire at the bottom. I had been very careful not to do this, but evidently I did. I cut, soldered and taped the broken wires and now the treadmill works again.

    Thanks to John for being the one to answer the phone for that Ebay post.
Sign In or Register to comment.